• GUESTS

    If You  want access  to member only forums on FM, You will need to Sign-in or  Sign-Up now .

    This box will disappear once you are signed in as a member.

  • Join In - We Share Fishing Reports & Outdoor Information Here

     
      You know what we all love...

      The same things you do!!!! Share what you love & enjoy in the outdoors as well as thank those whose posts you 'appreciate.'

      Have Fun!!!

  • 0
Sign in to follow this  
Wallydog

X125 Lowrance

Question

Wallydog

Anyone have any issues with driving rain penetrating the seal and causing the unit to crap out? It's only a year old.

I opened it last night and hope that after drying out it'll boot up again.

any thoughts?

Thx

WD

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
jigginjerk

Had my X125 in pouring rain a couple of times last year and have yet to have a problem.

Share this post


Link to post
Share on other sites
  • 0
PierBridge

It should work after drying out, how long that takes is another question.

Share this post


Link to post
Share on other sites
  • 0
andy j

I have had my X125 for two full season in some heavy rain and have not had any problems, I have had some units in the past that took in water (bottomline) but I have never had any issues with Lowrance or Eagle.

Share this post


Link to post
Share on other sites
  • 0
Wallydog

Dried it out well and it did re-boot..............yee haaa

Just need to re-seal it better than the factory did.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this