Guests - If You want access to member only forums on FM. You will gain access only when you Sign-in or Sign-Up on Fishing Minnesota.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
magic_minnow

Trolling Motor HELP!

4 posts in this topic

Hello All:

ok so, Im not too knowledgable about trolling motors, and I picked one up USED from a buddy of mine. Problem is that it doesn't work. My buddy said that it worked, am I just not hooking it up right? We were testing it on the car battery, is that why? The battery clips are rusted as well. If you have any knowledge or input, please help me, THANKS! Those crappies are laughing at me confused.gif

Share this post


Link to post
Share on other sites

try cleaning off the battery clips if you can - rust doesn't conduct electricity very well! sandpaper or a wire brush should work.

Also are you sure that the motor a 12 volt model? I don't have any experience with them but there are some 24 and 36 volt models out there...

Share this post


Link to post
Share on other sites

Thanks for replying Peepers. Yeah...its just a 17LB thrust motor...i'd assume its 12V. I will try to clean the clamps. My buddy got a sand blaster I could use. HEHE. The Sunnies are laughing at me now.

Share this post


Link to post
Share on other sites

are you sure you dont have to turn on a power button?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0