Guests - If You want access to member only forums on FM. You will gain access only when you Sign-in or Sign-Up on Fishing Minnesota.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
mnwild14

Etrex Legend display problem

1 post in this topic

I know I have seen the answer to this question before, but now that I have the problem I can't seem to find the answer. But when I power up my Etrex Legend (after putting in new batteries) the screen is blank. I can push the back lighting butting and the back light comes on and off, but I can't see any text. I thought there was something you needed to do to get it back, maybe something with the contrast. I tried it a little but I wasn't sure if I should be pushing the up or down button or if that was even the solution?

Thanks

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0



  • Posts

    • SaintPaulPaul
      Another beautiful day on the ice Thursday. I got skunked but my buddy Scott got a couple of nice ones- a 28" and a 29".
    • 401TE
      Are you saying people with better reports are being dishonest?  
    • Wanderer
      Feb 5 @ 5:25 pm.   But I couldn't tell ya who's playing. 
    • Wanderer
      Sounded like a good mix of fish.    The walleyes I lost were because I couldn't get a good enough hook set on em.  I was using my light action crappie rod with 2 lb test.  Even the ones I iced had the hook come out while the fish were in the hole.  I was just quick enough to get a hand on em.   I tried the same presentation on a walleye rod with 8 lb test and never actually got bit.
    • monstermoose78
      What day is that on