• RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

Sign in to follow this  
Gadgetman

Decent boat landings on Red

Recommended Posts

Gadgetman

I have been told that Rogers will not be letting people that are not staying with them use their landing this year. That being the case where is there a decent landing for a large boat on that side of the lake? Also, is the Tamarack river landing going to be usable this year with the low water problem? Just trying to make plans for the week after opener. Any suggestions by you guys that live up there are greatly appreciated.

Share this post


Link to post
Share on other sites
Mike L

Shotley Creek is so shallow that the campground folks won't be able to go out from Roger's. frown.gif

Share this post


Link to post
Share on other sites
Random guy

West Winds Resort has a great ramp and protected harbor. The Tamarac launches will also be fine, both ramps are placed in deep outside corners. I launched my 18' Crestliner yesterday without a problem.

Share this post


Link to post
Share on other sites
halad

Morts has a landing on the S. shore but its not protected so it can be tough getting out with a N,NW,W wind. Rogers is closed to normal people. Their landing should be ok they have a problem with high water big boats cant get under the bridge. Right now the lake looks about like last fall but until all the ice is out its hard to tell. Could use some more rain up here.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  



  • Your Responses - Share & Have Fun :)

    • monstermoose78
      Green has some nice gills. Glad to hear they are biting
    • Fully Kraeusened
      I’m wishing you luck my friend. It’s hard to get away and it can be very deflating when the weather doesn’t cooperate. 
    • MinDak Hunter
      Hit Green for a couple hours this afternoon, almost zero traffic and the sunnies were active. It’s nice to see this lake is back!
    • jigginjim
      still frozen in?
    • CigarGuy
      Was out for a while on the Partridge River this afternoon, didn't have any minnows, managed one 13" crappie on Gulp waxes.  But, the old Strikemaster almost bottomed out-close to 30" of ice.
    • SkunkedAgain
      I don't know what your Helix 7 requires in the manual, but a quick look would figure out if that 3amp is too small. Definitely wire your sonar to the motor battery using the correct gauge wire and fuse. If you connect it to another battery, it should be a stand-alone. Connecting to the trolling motor battery will generate interference.
    • SkunkedAgain
      I've done cheeks quite a few times and they are always good. They take only a few seconds to carve out. I like to get the most out of the things I kill to eat, so I'm not afraid to pull them out of smaller ones. I'm glad to see that so many people picked up a new tip. That's the point of congregating on these forums. I wonder how many non-registered folks will read this and learn something new.
    • CigarGuy
      I've been doing them for many years.  Like Cliff, a friend who was a guide on LOW brought some out prior to the main course-been doing it since. 
    • Tom Sawyer
      With the snow cover completely gone and lots of standing water, 60s in the forecast, with plenty of sunny days next week, and a good chance of rain mid-week; this may be my last weekend on the ice, South of Hwy 210 anyway . Fish have really been on the chew
    • Alex wilhelmi
      hey guys..i installed the helix 7. took it out the other day. it keeps  randomly shutting down, with the motor off it will stay on no problem. Heres where i think i f'd up. i used the same 3 amp fuse harness from the old sonar that came with the boat, the old hb depth only kind. its wired right to the ignition wire. i used the correct gauge wire where i needed it. im guessing its not getting enough juice? also if i wired it direct to a separate battery, how do i go about hooking up and on board charger? or would i be ok just wiring direct to the battery that runs the motor? thanks for any advice. those musky lures look so bad ass! nice work !!