Jump to content
  • GUESTS

    If You  want access  to member only forums on FM, You will need to Sign-in or  Sign-Up now .

    This box will disappear once you are signed in as a member.

  • 0

Evinrude Outboard won't kill!


stiffwater

Question

Hoping someone can point me in the right direction on this one.

I have a 15hp Evinrude outboard (Model E15RElERE, mid-late 90's model)on a pontoon I purchased last fall. This past weekend it no longer shutoff with the ignition key and/or emergency kill. I haven't had a chance to troubleshoot the system at all. An ideas of where to start?

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

On a pontoon it has to be a remote control, right ? (Better be right, it would be one goofy looking thing a tiller-pontoon.... grin.gif)

Anyway motor is a 1994, it could be something in the main harness at the motor or at the remote control.

Check your wiring inside hood and see if the big red connector from main harness is doing good.

Also check your remote control if it has any loose wire.

Link to comment
Share on other sites

  • 0

Thanks Valv!

Yes, its on a remote control...that would be one goofy setup with a tiller grin.gif

I'll start with your suggestions when I'm up at the cabin over Mem wknd.

Thanks again.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.