Jump to content
  • GUESTS

    If You  want access  to member only forums on FM, You will need to Sign-in or  Sign-Up now .

    This box will disappear once you are signed in as a member.

Lund Pro -V livewell problem


Recommended Posts

I recently left my recirculator running to keep some minnows alive over nite. In the AM all the water was out of the livewell. The plug is in and is tight. Is it a problem with the drain plug or something to do with the reciculator. I am not sure the mechanics of the recirculator. What should I try or look for. any help would be appreciated. Thanks Kevfish

Got Perch?

Link to comment
Share on other sites

Kevfish,if you normally keep your"bilge"area dry by routinely
running your bilge pump and it now is holding water chances are you have sprung a leak in your recirculator line.To verify,empty the bilge area of any standing water, fill your livewell and then run recirculator and watch to see if the livewell water level drops. If you now have water in the bilge area it's time to gain access to your recirculator pump and line. My suggestion is meant to save you from having to unecessarily try to gain access to the recirculating pump and line if that's not where the "problem" lies. I have an older Pro-V and have just replaced the pump. Good luck, Dockehr

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.