Jump to content
  • GUESTS

    If You  want access  to member only forums on FM, You will need to Sign-in or  Sign-Up now .

    This box will disappear once you are signed in as a member.

  • 0

Lowrance X 104 problem


PropsterII

Question

Buddy has an X-104 and when he turned it on tonight all he gets is a white screen. He will call Lowrance tomorrow and see if it is an easy software fix, but anybody have this happen to them and have an idea what it may be? Buttons all sound as though the unit is responding just no visual. Software, hardware, or shot? Anybody have an older 104 they may be interested in selling? Thanks

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.