Jump to content
  • GUESTS

    If You  want access  to member only forums on FM, You will need to Sign-in or  Sign-Up now .

    This box will disappear once you are signed in as a member.

  • 0

Lowrance LMS 522 trouble


justplainbob

Question

justplainbob

Good morning. My Lowrance is giving me trouble again. When I zoom in on a lake, the zoom in only lasts a few seconds and then it zooms out.

Also, the depth intermittently flashes an erroneous depth, even when sitting still.

Anyone have any fixes for this. I just dread the thought of sitting on hold for 2 hours waiting for Lowrance customer service.

I am temtped to start looking at Hummers.

Thanks.

Link to post
Share on other sites

21 answers to this question

Recommended Posts

  • 0

Go buy a replacement transducer it will act like a new machine compared to what you are seeing now. Thats what I did for mine after being told on here about a transducer problem with them.

  • Thumbs Up 1
Link to post
Share on other sites
  • 0
CaptainMusky

I have called Lowrance Customer Support 3 times over the summer and never once did I wait on hold for more than 5 minutes.

Having said that, I do not believe they will be able to help you much because I dont think they are repairing those models anymore and will push you towards a new one.

A transducer may help your depth problems, but the zooming issue has be perplexed. Is it zooming in the depthfinder mode or chart?

Try doing a reboot of the system. It usually is done by pushing two of the buttons at the same time and holding them. You can find out for sure on that model by your owners manual, if you do not have one they have them on lowrance's site for download.

Link to post
Share on other sites
  • 0
LundProAngler

I have called Lowrance Customer Support 3 times over the summer and never once did I wait on hold for more than 5 minutes.

I have also gotten thru with a minimal wait.

Give it a try.

Link to post
Share on other sites
  • 0
harvey lee

You will more than likely always have an issue with that unit. I had one and it worked fine and I replaced the transducer once. Worked fine after that and I also did a hard reset a few times to correct issues.

I sold it to a person I know as it was working fine when I sold it and then not much later, mkore issues. I wish I would not have sold it to him as he has had so many different issues with it.

For what it is worth, that unit is a bad one to say the least and ve few have ever gotten the issues fix for a long time even with Lowrances help if you could get some. Then for what they charge to fix the unit, I believe your best bet would be to purchase another new unit. I realize that new units are not cheap but if you look at the fact that more than likely you will continue to have issues with that unit, I believe you would be better off in the long run to buy a new one and save all the repair money you spend on a unit that probably give you more issues.

For the shallow water issues. try a hard or soft reset as that did help my unit out, at least for awhile as the guy I sold it oo, had issues after he got it from me. or a transducer but the reset would be worth tryoing as it will cost you nothing to try and may save you the expense of a new transducer.

You mentioned Humminbird and I purchased 2 new units with Side imaging. There have been a couple upgrade for my units which they sent to me and I put them in the unit. I really like the fact that they send you these upgrades to fix common issues with their units to fix the issues for free.

Not knocking Lowrances new units at all but I also had a GPS unit from Lowrance-a H20 and had tons of issues with that also. They did sell me the replacement parts but waiting on hold forever was nopt good CS to me.

Link to post
Share on other sites
  • 0
justplainbob

Thanks for all the replies, guys.

I am currently on my 3rd transducer. I have tried both hard and soft resets to no avail. Looks like I might just have to bite the bullet and go shopping for a new unit. Now I just have to decide between Lowrance and Humminbird.

Link to post
Share on other sites
  • 0
delcecchi

For what it is worth, Lowrance is literally not the same company. They got acquired and the new owners seem to be trying hard to make good products. I certainly haven't heard much bad about them recently, and given their rep from before, I would expect to if something was a problem. Got my fingers and legs crossed that my two older units keep working.

Link to post
Share on other sites
  • 0
gofishingtom

go to blueheronmarine and look up lowrance simrad P66-BL tranducer made by airmar which is a transducer company that has been around for years the ducer runs 129 but is 10times better then what lowr. puts out for 80 bucks help me out alot and i havent had any issues since i changed over 2 years ago..

Link to post
Share on other sites
  • 0
Juan Grande

I had the same problem with the flashing depth, even when it wasn't moving. Got a new transducer and it works like a champ. I have the 332c

Link to post
Share on other sites
  • 0
dudewheresmyboat

If you haven't done the software update I would try that and the new ducer. Good Luck, I guess i got lucky with my unit, so far so good.

Link to post
Share on other sites
  • 0
justplainbob

I called Lowrance at 9am our time this morning and got thru on the first ring! Sounds like things have changed.

They seemed to think that since my depth-reading problem was intermittent that it must be the 'ducer; if it were constant it would be in the unit itself.

I went ahead and orderd the Blue heron transducer. As for the "zoom" problem, I mistakenly had it set on "auto zoom".

A guy learns something new every day!

Link to post
Share on other sites
  • 0
CaptainMusky

I called Lowrance at 9am our time this morning and got thru on the first ring! Sounds like things have changed.

They seemed to think that since my depth-reading problem was intermittent that it must be the 'ducer; if it were constant it would be in the unit itself.

I went ahead and orderd the Blue heron transducer. As for the "zoom" problem, I mistakenly had it set on "auto zoom".

A guy learns something new every day!

Great! I hope the new ducer works for ya. It is overwhelming how much you hear bad stories about Lowrance Customer Support, but it is MUCH better and I believe they received an award recently in fact.
Link to post
Share on other sites
  • 0
harvey lee

Great to hear that Lowrance is better in regards to CS.

Too bad that do not give a guy a break on the price since their ducer were such junk.

Link to post
Share on other sites
  • 0
Capt. H (Ret.)

I have owned the LMS 522C IGPS for 3-4 years and have not had any trouble with it. Is this the smae one you are all talking about.

Link to post
Share on other sites
  • 0
LundProAngler

Too bad that do not give a guy a break on the price since their ducer were such junk.

I have had no problems with my transducer. Why are they being referenced as junk?

Link to post
Share on other sites
  • 0
harvey lee

Good to hear that you have been one of the few lucky ones with a 522.

I guess if you would read all the post about the 522, then you may understand why I stated what I did. The majority have had issues from the posts I have read over the past few years.

I might guess that 90% of the posts in this forum have been negative.

Link to post
Share on other sites
  • 0
delcecchi

My 522 has been pretty solid, using the US2 in the Terova. But the 3xx is on its third transducer. And they use the same transducer.

Link to post
Share on other sites
  • 0
LundProAngler

I might guess that 90% of the posts in this forum have been negative.

One might guess that 99% of your posts are always informative and true.

One might guess that we are lucky to have such a intellegent contributer with 25000+ posts.

Thank you HL for setting me straight. grin

Link to post
Share on other sites
  • 0
Coreykost

- Lms 522c shuts off and on intermittently 

- screen locks up

- sometimes sonar works, but map don't?

-has mind of its own!

- sometimes works for a second, - --

- sometimes we've used all day without problems?

- clean batt connection

- new ducer

what seems to fix this?

 

 

Link to post
Share on other sites
  • 0
gunner55
On 10/26/2011 at 9:41 PM, gofishingtom said:

go to blueheronmarine and look up lowrance simrad P66-BL tranducer made by airmar which is a transducer company that has been around for years the ducer runs 129 but is 10times better then what lowr. puts out for 80 bucks help me out alot and i havent had any issues since i changed over 2 years ago..

We had a 05-06 520c & it had issues right out of the box so we did just as gofishingtom suggested above. Not the same unit but I know a lot of those  models with the blue 5 pin connectors in the back of them had similar problems. Ours worked fine after that & we just upgraded last season. I believe Lowrance is now owned by Simrad's parent company, Navico.

Edited by gunner55
Link to post
Share on other sites
  • 0
delcecchi
On 5/9/2020 at 4:11 PM, Coreykost said:

- Lms 522c shuts off and on intermittently 

- screen locks up

- sometimes sonar works, but map don't?

-has mind of its own!

- sometimes works for a second, - --

- sometimes we've used all day without problems?

- clean batt connection

- new ducer

what seems to fix this?

 

 

I decided that those transducers had issues with being stored at freezing temperatures.   Could be my imagination or coincidence but once I started storing the transducers in the house in  the winter, no more problems.     

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Your Responses - Share & Have Fun :)

    • eyeguy 54
      That was it. We discussed on ice today if smurfy was a human or a bot. Bot won  
    • Wanderer
      I think he cancelled because you bailed! 😄
    • Wanderer
      That’s even looser than it was before.  It was always an issue with tournaments and when I fished some of the out of state events you couldn’t cull at all and had to quit fishing once you boxed your limit.  MN tourney limits were always 1 under the state limit to comply.
    • smurfy
      So technically speaking then I'm not bailing, right!!!🤪🤭😉
    • eyeguy 54
      👍🏻
    • Wanderer
      Tournament exception only - from working live wells.     Been that way for years so if it’s different now it’s been a recent change.  
    • eyeguy 54
      You can’t cull from box or bucket? My bucket is full of water and have culled on ice a few times. But only if lively fish
    • Wanderer
      Not supposed to do that...  We don’t take it as serious in MN as other states but once it’s in the box, bucket, shore or on the stringer, you own it.
    • eyeguy 54
      Good idea captain Ricky 
    • Rick G
      I really hate to do this, but after seeing what the access points around the Richmond area looked like when I left the lake today. I am going to cancel this year's cool cats. I do not feel the access on Horseshoe with Hold up to vehicle traffic though the week. The main lake ice will almost certainly be good for a while yet.  But, the access  will not be useable after another day or two of traffic.   
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.