• GUESTS

    If You  want access  to member only forums on FM, You will need to Sign-in or  Sign-Up now .

    This box will disappear once you are signed in as a member.

  • WE CREATE LONG TERM, MEANINGFUL RELATIONSHIPS IN HERE ... PLEASE JOIN US.

    You know what we all love...

    RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE
    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

  • 0
Sign in to follow this  
badfish

Abu Garcia C3 Ambassadeur

Question

badfish

I'm having drag problems with the reel I just purchased. Ive only used it once for about an hour and all of a sudden it wouldnt reel up my lure, it would reel up slack line but nothing heavier. Then I noticed my drag isn't working at all, I took it all apart and oiled it up real good I put it back together and now it only reels when it wants to and the drag still doesnt work. I don't know whats wrong I just bought this reel mad.gif...anyone have any ideas??? thanks.

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
Wade Joseph

You probably need new drag washers. If they got "oiled up real good" they are probably slipping from too much oil.

Share this post


Link to post
Share on other sites
  • 0
DTro

well that's easy. If you "just bought it". Return it for a different one.

Share this post


Link to post
Share on other sites
  • 0
jerk bait

Are you sure the line isn't slipping on the spool?

Share this post


Link to post
Share on other sites
  • 0
Wade Joseph

AHHHHH, Good question. Mono or power pro type superline? if you didn't tape it at the beginning or put on some mono backing, the power-pro/spiderwire type line will slip on the spool.

Share this post


Link to post
Share on other sites
  • 0
badfish

thanks jerk bait and wade, I feel like an (Contact Us Please) now blush.gif, I had power pro on there and i've never had any other problems on any of my other baitcasters, but it sure was slipping on this one....now i'll never make that mistake again, thanks everyone

Share this post


Link to post
Share on other sites
  • 0
Wade Joseph

Hahahaha, its cool, jerkbait deserves the credit. Glad to see we could help.

Share this post


Link to post
Share on other sites
  • 0
harvey lee

Seems there is always someone on the equipment forum that can answer just about any question. Gotta love this forum.

Share this post


Link to post
Share on other sites
  • 0
hanson

You have no idea how many people this happens to. Its a very common mistake when spooling superlines. If you don't put electrical tape around the spool first, or use mono backing, its not a matter of if it will slip, its a matter of when.

Good to hear you got it figured out!

Share this post


Link to post
Share on other sites
  • 0
Borch

Quote:


You have no idea how many people this happens to. Its a very common mistake when spooling superlines. If you don't put electrical tape around the spool first, or use mono backing, its not a matter of if it will slip, its a matter of when.

Good to hear you got it figured out!


Yep,

Just happened to my nephew on our family vacarion with his new 5600 C3 reel. After messing with it for 10 minutes I asked him if e used any mono backing. No he didn't and I knew it was his spiderwire slipping on the spool.

Happens to a lot of folks.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

Announcements



  • Your Responses - Share & Have Fun :)

    • Wanderer
      +1 on the trim tab being the issue.
    • PRO-V
      Did you do anything to the lower unit? Trim tab might need adjusting.
    • vermilionfox
      Looks good Cliff! The perch look mighty tasty!
    • vermilionfox
      I recognize where those pictures were taken!  
    • Dave38
      25 HP Merc on 14 ft Lund pulling hard to right???
    • cookie129
      Another weekend is in the books. The guys in the cabins did all right but the fishing did slow. maybe due to the water getting stirred up from the winds and the cold front that moved through.. today Monday looks like its shaping up to be a beautiful day. ken is here for a couple days and scott and his parents are coming tomorrow for a day or two. The kids will be coming for the holiday weekends so I guess I better get the boat in the water this week. I held off due to the low water but the park was able to jump through some hoops and dig out the channel so I think I'm ok.  The access was crazy busy yesterday and I still have no clue where they all come from. I guess its just a combination of  other resorts and people with cabins with in 100 mile radius.
    • Tripp_315
      Nice way to check water temps lol ~Tripp
    • FishandFowl
      Have not been here in sometime. Thought this would be a good opportunity to get back on here. Got out for the C season, arriving just before sunrise  and the birds were already on the ground. Started with an aggressive calling sequence "Purr into a loud Yelp" there were birds North and West of my location responding. This guy decided to take a look about 30 minutes later. He got within 5 feet of my blind full strut. Something I have never heard before he started to hiss at the decoy.  Not a great shot at that range but sealed the deal.   
    • Wakemup
      Very nice! I was kicking myself real hard this weekend for forgetting my fish finder at home. I did manage to bring this smallie in, but they were tough to pattern for me and this was the only noteworthy fish of the weekend. Hope the water temps come up and I can get back next weekend!
    • Wakemup
      Nice boat Raven! I think I saw you out buzzing around in Wakemup this weekend!