Guests - If You want access to member only forums on FM. You will gain access only when you Sign-in or Sign-Up on Fishing Minnesota.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
finny

bait well problem

6 posts in this topic

Anyone know how to fix a bait well. My pump is fine but it does not pump water into the well. I think that my line must be plugged. Has anyone had this happen to them before and how did you fix it??

Share this post


Link to post
Share on other sites

Is this a new boat? If so it is very possible that the spray nozzle is shut all the way, thus not allowing water flow. Reach in to the baitwell and find the nozzle. Simply unscrew the nozzle a couple of turns and water should flow. If this a used boat you may have a bad impeller on your aerator pump. Greg

Share this post


Link to post
Share on other sites

Is it a Ranger boat? If so you may have to purge the line. You should have a black plastic cap on the floor with the valves under it. Try that and see if thats the problem. Thats if you have a Ranger but from looking at your avator Im just assuming.

Share this post


Link to post
Share on other sites

I've read that you can take a garden hose and spray it from the back to see if it's plugged or not. Take the screen off where the livewell normally drains from and shoot some water through the pump and up into the livewell. This might unblock anything you've got in the lines.

Share this post


Link to post
Share on other sites

Yes it is a ranger. My impeller and pump is fine. This may sound stupid but how do I purge the line? Thanks

Share this post


Link to post
Share on other sites

Sometimes the lines get air locked - make sure the valve for your baitwell is on fill (or whatever setting is required to fill it) and put the motor in reverse, forcing some water into the tube - that'll usually do it if everything else is working correctly.

marine_man

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0



  • Posts

    • KidMoe
      I'm thinking the same thing!  When will I get another chance to target walleyes and bass with a long rod in February!
    • loadmaster
      Was up yesterday.  Tried going out of Stoney Point the sand landing is undo able ice ridge out a ways and did not see any tracks going out.  The boat launch has a pressure ridge in front and looked like ATV were following the ridge  toward the point.\ There were two trucks out there no idea how they got there.  we finally went out of Pine Point.  Ice conditions are perfect. No slush no water on the road,   You cannot get out to the trench from here ice heave between. We drilled some holes and a lot of  5 inch perch. When we were going out we asked if the tullies were biting,and he said no  not yet Seems to shallow out any where out there. The was in excellent shape as a lot of wheel houses were coming out.  4 wheel drive was not used all day.  Ice cleats would have been nice to have.Hope this helps 
    • BRULEDRIFTER
      Most of the mercury pollution in our lakes is from rain.  That's why lakes deep in the back country also have consumption advisories. 
    • curt quesnell
      Looks like a beauty of a weekend...Here is what you want/need to know.  Good Luck everyone
    • mnorth
      Drove by Grays Bay this morning. The one and only house left has now partially fell thru. Not sure how this one is coming out.