Guests - If You want access to member only forums on FM. You will gain access only when you Sign-in or Sign-Up on Fishing Minnesota.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
Badger_55

99 Yamaha 60hp outboard?

2 posts in this topic

hey guys I noticed that the water cooling stream coming from the small jet on my engine is not a defined stream anymore. Yes there is continuously water coming out to the motor while running but it isn't a nice defined stream it is more like a fanned stream of water or what you would call a "Viper piss"! What do you guys think? I did force some air back down through hoping it was just something blocking the line.

Share this post


Link to post
Share on other sites

I would replace water pump impeller, if you haven't done it yet on a '99 it's way past due.

Also never blow air trough the hole, pressure might disconnect some hoses from their fittings.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0



  • Posts

    • brmurph
      Wow.  Any details?  Like was he on the marked/stacked trail?
    • eyeguy 54
      fun time on new ice.   no pics today. I was lazy...  lol 
    • monstermoose78
    • monstermoose78
      Went up north today with @eyeguy 54 and we found plenty of ice if the access would have been better we would have driven out. We fished hard as both of us have similar fishing styles. We jump hole to hole picking off the aggressive fish with plastics. The wind did not do us any favors but we still caught a good number of fish. If eyeguy took photos maybe he will post em. Thank you eyeguy for the call I wanted to get out fishing today. 
    • monstermoose78
      Went to a small lake up around Mille lacs lake and found 20-28 inches of ice. The access looked like some busted it up, so eyeguy and I walked out. We caught bluegills and crappies on plastics. It was windy and cold but we got a few nice ones.