Guests - If You want access to member only forums on FM. You will gain access only when you Sign-in or Sign-Up on Fishing Minnesota.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
Ham

power trim

6 posts in this topic

power trim worked last winter before storage, pull out of barn over weekend motor will not go up or down. can hear ele motor run. how do i get motor to fluid

Share this post


Link to post
Share on other sites

We need to know which motor brand, year, and model.

Share this post


Link to post
Share on other sites

Should be a fill and level plugs on side or top of unit or resivor. What kind of unit do you have? Does it move at all?

Share this post


Link to post
Share on other sites

92 Mariner The drain plug did break the small end in pump. Is that why it wont go up and down but make noise. It worked when I put it away. Very new to this.

Share this post


Link to post
Share on other sites

Can you see any leakage? The noise you hear is most likely to be caused by "air" in system. You need to get air out of there. Fill reservoir with proper type of fluid. If their is a bleeding process posted on unit follow this. I know some only require filling reservoir and running unit up and down until full travel is achieved. Good Luck.

Share this post


Link to post
Share on other sites

Ok thanks for the info

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0