Guests - If You want access to member only forums on FM. You will gain access only when you Sign-in or Sign-Up on Fishing Minnesota.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
jighead 3

snowmobile question

4 posts in this topic

i have a 1994 polaris 440 indy the sled starts after a couple of pulls but when i give it some gas it bogs out and dies what should i check to fix problem please help

Share this post


Link to post
Share on other sites

Sounds like gumed up carbs to me, pull them off take apart clean with deep creep and put back together.

Share this post


Link to post
Share on other sites

Yep.

Carbs are the culprit. Take them off the sled, dump the gas out, remove the jets & spray them out, and generally clean the carb good with carb cleaner.

Make sure you've got fresh gas as well.

Share this post


Link to post
Share on other sites

Carbs, it's always the carbs. You have to clean them out every year (no exceptions). Snowmobilefanatics website has a good article that will walk you through it.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0



  • Posts

    • leech~~
        Oh, says the guy that just took the plunge! I'm sure it will do your little pan fish ok. Let me know if you need a few Walleye's to try?
    • ZachD
      My buddy dulled his blades against a brick first thing when he got his. still cuts awesome just not through bones 
    • eyeguy 54
      you should have taken lessons    
    • leech~~
      I had a battery op Repala a few years ago and sold it to someone else at our campground. Didn't like the way they just zipped through without following the fillets and lost a lot of meat. Really suk's on a partly frozen fish!   Mine came with a case.
    • eyeguy 54
      decided to take the plunge and bought a Rapala Ion rechargeable. anybody have one and what do you use for a case?