Guests - If You want access to member only forums on FM. You will gain access only when you Sign-in or Sign-Up on Fishing Minnesota.

It's easy - LOOK UPPER right menu.

  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

  • 0
Sign in to follow this  
jighead 3

snowmobile question

Question

jighead 3

i have a 1994 polaris 440 indy the sled starts after a couple of pulls but when i give it some gas it bogs out and dies what should i check to fix problem please help

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
deepportage01

Sounds like gumed up carbs to me, pull them off take apart clean with deep creep and put back together.

Share this post


Link to post
Share on other sites
  • 0
hanson

Yep.

Carbs are the culprit. Take them off the sled, dump the gas out, remove the jets & spray them out, and generally clean the carb good with carb cleaner.

Make sure you've got fresh gas as well.

Share this post


Link to post
Share on other sites
  • 0
MuskieJunkie

Carbs, it's always the carbs. You have to clean them out every year (no exceptions). Snowmobilefanatics website has a good article that will walk you through it.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this