Guests - If You want access to member only forums on FM. You will gain access only when you Sign-in or Sign-Up on Fishing Minnesota.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
1tofish

Pro-V lLive Well Question?

3 posts in this topic

I'm posting this for my friend who needs some trouble shooting help with a live well on his Pro-V.

He has a 2006 18ft. Tiller. On occasion the front live well fills with water when he is moving. He has the lever in the closed position and does not have the live well on.

We are guessing the valve is still open to some degree. Is there any adustments that he can make?

Thank you for any and all suggestions!

Share this post


Link to post
Share on other sites

The pickup and the pumps are in the rear of the boat, so I would doubt that you could pick up water when boat is in forward motion. Is the plug in the hole at the bottom of the live well?

Share this post


Link to post
Share on other sites

I agree with Down Deep. Check to see if the plug is in and in tightly.

My 2001 Lund Mr. Pike does the same thing. (Front live well fills with a few inches of water. Rear live well is dry.) In my case, I'm sure it's the plug leaking.

Not a big problem for me because I'm probably going to fill the live well with water anyway and usually run long distances.

He may want to get a new plug. They can lose flexibility and get hard with age. Worth a try.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0