Guests - If You want access to member only forums on FM. You will gain access only when you Sign-in or Sign-Up on Fishing Minnesota.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
pointer

marcum vs560 fogging

7 posts in this topic

ive a marcum vs560, noticed fogging on clear band that camera turns toward,, moisture leak of concern? it will clear somewhat after being in water for a bit ,, but like looking through a fogged window when starting,,

Share this post


Link to post
Share on other sites

I would contact MarCum customer service, Jon or Chris are fantastic and they will get you fixed up fast, (763)712-0886

Share this post


Link to post
Share on other sites

I noticed the same thing on my 560.

Share this post


Link to post
Share on other sites

after checking camera over i noticed a rack that runs dead center of fin both horizontal as well as vertical , amazed it dead center all the way. reminds me of a stress crack in concrete. this is causeing the band around lights to allow slight water in. thus moisture and fogging prob. has quit using to avoid major probs. am stuck to using my lx5 flasher only. poor me..lol but has anyone else had ths same prob of cracking? im very careful so cant imagine how id of done it.

Share this post


Link to post
Share on other sites

( Note from Admin,please read forum policy before posting again,Thank-You.)

Share this post


Link to post
Share on other sites

After seeing lots of problems with leaking cameras, I went with the Aqua-Vu.

I'm glad I did.

Share this post


Link to post
Share on other sites

They can all have leakers. When I bought my AquaVu about three years ago the first two were leakers.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0