Guests - If You want access to member only forums on FM. You will gain access only when you Sign-in or Sign-Up on Fishing Minnesota.

It's easy - LOOK UPPER right menu.

  • Announcements

    • Rick

      1st Please Post Your Fishing Report - Then Join the NEW - Private Fishing Report Clubs   01/24/2018

      Private Fishing Report Clubs - Click Here - Post Your Fishing Report Before Joining
      1st, be sure you post a fishing report in the forums, then ask to join after you post a fishing report in your area forum. The Private Fishing Report Clubs are where folks can share private fishing information with club members who have proven they know what's going on. Fishing Report Clubs Link also in Menu above. Apply to become a member today, while it's still easy. 
  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

  • 0
Sign in to follow this  
wazz

Motor HelP

Question

wazz

My motherinlaw has a 80hp Envirude, it starts hard, but it starts, it idles great and would do so all day if you let it. The problem is when you put a load on the engine it dies. Everytime you put it in gear, the motor dies.

Any Input? confused.gif

Wazz

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
eurolarva

Standard reply for this is to test compression and spark first. My guess is that it is fuel related. Probably a ruptured diaphragm in the fuel pump or the carb is dirty and needs rebuild. The reason for the compression and spark test is if one or both of these fail the motor could be trashed and spending money on carb and fuel pump kits will be a waste of money.

Share this post


Link to post
Share on other sites
  • 0
Surface Tension

Hard starting and won't run with a load. I think your not getting enough fuel or it could be compression.

Do you have manual of electric choke? Is it working?

Check these, compression, gas lines and connections for air leaks, & fuel filter. Fuel line bulb, when you squeeze it does it stay hard and full when idling? If all those check out then I'd turn to the fuel pump and a carb cleaning.

Share this post


Link to post
Share on other sites
  • 0
The_Duckslayer

I just had that happen on my motorcycle. The issue was gas in the fuel. May want to look for that as well. Take care and N Joy the Hunt././Jimbo

Share this post


Link to post
Share on other sites
  • 0
marine_man

Quote:

The issue was gas in the fuel


Nothing worse than gas in the fuel... grin.gifj/k

maybe water in the gas?

marine_man

Share this post


Link to post
Share on other sites
  • 0
Macgyver55

Quote:

Quote:

The issue was gas in the fuel


Nothing worse than gas in the fuel... grin.gifj/k

maybe water in the gas?


Knowing Jimbo somewhat...he may have been doing some testing of his own and injecting some other type of "gas" into his fuel!

Careful Jimbo...results may vary! confused.gif

Share this post


Link to post
Share on other sites
  • 0
Kingfisher

If you haven't tried a new set of plugs, start there.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  



  • Your Responses - Share & Have Fun :)

  • Share & Have Fun