Guests - If You want access to member only forums on FM. You will gain access only when you Sign-in or Sign-Up on Fishing Minnesota.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
Giant_Jackpot

Lowrance 520c Issue?

7 posts in this topic

When running a 520c in split screen mode (sonar/GPS), when the unit is powerd off and then on again, shouldn’t the screen come back up in the same configuration as it was when it was powered off? I have a friend that has a 520c and we both thought the settings should stay the same after power off but his always comes back up with just the GPS screen. Is there a setting we are missing or is this just the way it is?

Share this post


Link to post
Share on other sites

Mine does the same thing. I believe that you need to set it to the screen you would like each time you turn it on.

Share this post


Link to post
Share on other sites

All my units do that too and I wish it would go to sonar.

Haven't seen anything in the menus that allows you to set your preference screen.

Share this post


Link to post
Share on other sites

My 332s do that also, I believe it is something new after the latest update but I don't know for sure. Funny how the little things like that get so (Contact Us Please) annoying.

Share this post


Link to post
Share on other sites

PJ,

You are probably correct about this being caused by the latest updates. Another friend runs two 332c units and both of his stay where he left them after powering off/on. They are last years models and knowing him, I doubt he has done any updates. Hard to believe that Lowrance does not consider this an issue since you can save your other sonar settings like auto sensitivity off etc. Grrrrrrrrrrrrr…………

Share this post


Link to post
Share on other sites

GJ-

You are not missing anything. It's the latest and greatest software (in new locators too) from Lowrance. crazy.gif My 25C never did this until I uploaded 1.7 software.

Hopefully Lowrance will bring out a new software soon, because I would really like to see the bottom 20' of water and weeds too.

Share this post


Link to post
Share on other sites

I am also finding that some of my network settings are changing when I power off the units. Very annoying.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0



  • Posts

    • Stick in Mud
      Thanks for the ice report, Sculpin.  With the weather forecasted for the upcoming week, I'm sure I'll be up there next weekend, hopefully walking out from the northwest side.   van, yeah, I hear you.  I've been up to LOW a few times, and it is very fun to know there's the chance of catching a monster....but driving all that way for a bucket full of 12'' fish?  Not my cup of tea. I'll save the money and buy three dozen T-bones to make it through the winter. I'm sure people who know the lake better than I do have done better on the weekends I'm up there, but the reports at the resort we used were pretty similar.    I like the northwest side on ML because it's where we've been for almost 20 years, but it also has close access to sand, rocks, whatever weeds remain, mud flats, transitions, etc. The only thing we don't have up there is extensive gravel.
    • BassThumb.
      I'm curious to see how this works out. Do you plan to keep the battery warm while not is use on the water? 
    • Vitreus
      How much ice??????
    • Vitreus
      Picked up a couple of these (jigging rap with wings!):  
    • eyeguy 54
      didnt need hair dryer,  it went back to normal on it's own. paint chipped also.  nice idea the flat tip, just not for me I guess.