Guests - If You want access to member only forums on FM. You will gain access only when you Sign-in or Sign-Up on Fishing Minnesota.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
Giant_Jackpot

Lowrance 520c Issue?

7 posts in this topic

When running a 520c in split screen mode (sonar/GPS), when the unit is powerd off and then on again, shouldn’t the screen come back up in the same configuration as it was when it was powered off? I have a friend that has a 520c and we both thought the settings should stay the same after power off but his always comes back up with just the GPS screen. Is there a setting we are missing or is this just the way it is?

Share this post


Link to post
Share on other sites

Mine does the same thing. I believe that you need to set it to the screen you would like each time you turn it on.

Share this post


Link to post
Share on other sites

All my units do that too and I wish it would go to sonar.

Haven't seen anything in the menus that allows you to set your preference screen.

Share this post


Link to post
Share on other sites

My 332s do that also, I believe it is something new after the latest update but I don't know for sure. Funny how the little things like that get so (Contact Us Please) annoying.

Share this post


Link to post
Share on other sites

PJ,

You are probably correct about this being caused by the latest updates. Another friend runs two 332c units and both of his stay where he left them after powering off/on. They are last years models and knowing him, I doubt he has done any updates. Hard to believe that Lowrance does not consider this an issue since you can save your other sonar settings like auto sensitivity off etc. Grrrrrrrrrrrrr…………

Share this post


Link to post
Share on other sites

GJ-

You are not missing anything. It's the latest and greatest software (in new locators too) from Lowrance. crazy.gif My 25C never did this until I uploaded 1.7 software.

Hopefully Lowrance will bring out a new software soon, because I would really like to see the bottom 20' of water and weeds too.

Share this post


Link to post
Share on other sites

I am also finding that some of my network settings are changing when I power off the units. Very annoying.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0



  • Posts

    • AlwaysFishing23
      Looks fun Eyguy. As normal no time to get out but did just finish up cleaning and checking over the yak so maybe thats a sign. Haha.
    • AlwaysFishing23
        Yes sir! 8ft-9ft rods seem to work the best IMO.
    • AlwaysFishing23
      Yep James at tackle industries.
    • Troy Smutka
      4/23/17     Crappies still biting in west Metro area lakes. Water temp in the mid 50's now, and the fish are moving a little shallower. We caught tons of 8 to 11 inch crappies in about ten feet of water, with some weeds on the bottom. Fished a jig tipped with a Powerbait minnow about four feet below a slip-float for great success. Some sunfish starting to show up in the same areas. Water temp probably won't rise much this week with the forecast of cooler temps and quite a bit of rain, but as the water does warm fish should continue to move shallower and get more aggressive. Check out my You Tube channel for some short video clips and a full length show about springtime crappie fishing. Good luck, and I will see you out there somewhere.
    • monstermoose78
      Good luck with your season. It was nap time